Dodaj do ulubionych

Mdk 10.1 - problem z Qt3 [Długie]

11.04.05, 10:25
Witam :) Nurtujący mnie już od jakiegoś czasu problem poruszyłem już na forum mandrake.pl, ale tam niestety nie udzielono mi żadnej porady, zatem postanowiłem napisać tutaj :) Miałem kilka przygód z programami odmawiającymi kompilacji z powodu braku bibliotek qt3, zatem postanowiłem zainstalować to, co potrzebne ;) Problem pojawia się podczas instalowania libqt3-devel. Przy użyciu urpmi wygląda to następująco:

[root@jamez jamez]# urpmi libqt3-devel
wszystko zostało już zainstalowane

ale za chwilę...

[root@jamez jamez]# rpm -qa |grep qt
libqt3-3.3.3-27.1.101mdk
qt3-common-3.3.3-27.1.101mdk
libqt3-psql-3.3.3-27.1.101mdk
libqt3-odbc-3.3.3-27.1.101mdk
qt3-example-3.3.3-27.1.101mdk
libqt3-mysql-3.3.3-27.1.101mdk

ślepy nie jestem jeszcze, może źle widzę, ale nie ma...

próbowałem chwilę potem zainstalować w taki sposób (po uprzednim zassaniu rpma):

[root@jamez jamez]# rpm -i libqt3-devel-3.3.3-27.1.101mdk.i586.rpm

ale odpowiedziano mi:

błąd: Niespełnione zależności:
XFree86-devel jest wymagany przez libqt3-devel-3.3.3-27.1.101mdk
devel(libaudio) jest wymagany przez libqt3-devel-3.3.3-27.1.101mdk
devel(libfontconfig) jest wymagany przez libqt3-devel-3.3.3-27.1.101mdk
devel(libfreetype) jest wymagany przez libqt3-devel-3.3.3-27.1.101mdk
devel(libICE) jest wymagany przez libqt3-devel-3.3.3-27.1.101mdk
devel(libSM) jest wymagany przez libqt3-devel-3.3.3-27.1.101mdk
devel(libX11) jest wymagany przez libqt3-devel-3.3.3-27.1.101mdk
devel(libXcursor) jest wymagany przez libqt3-devel-3.3.3-27.1.101mdk
devel(libXext) jest wymagany przez libqt3-devel-3.3.3-27.1.101mdk
devel(libXft) jest wymagany przez libqt3-devel-3.3.3-27.1.101mdk
devel(libXinerama) jest wymagany przez libqt3-devel-3.3.3-27.1.101mdk
devel(libXrandr) jest wymagany przez libqt3-devel-3.3.3-27.1.101mdk
devel(libXrender) jest wymagany przez libqt3-devel-3.3.3-27.1.101mdk
devel(libXt) jest wymagany przez libqt3-devel-3.3.3-27.1.101mdk

i co ja, biedny, początkujący pingwin mam z tym począć ? :)
  • hanatol 11.04.05, 20:33
    Zainstaluj XFree86-devel a potem się zobaczy.
    (Tzn. nie wiem czy są osobne pakiety-devel dla tych wszystkich libXXX czy one są
    w pakiecie XFree86-devel).

  • kell99 12.04.05, 17:44
    tzn z tego co podal wynika, ze nie ma zainstalowanych praktycznie zadnych
    *-devel do kompilacji qt3. lepiej poszukac gotowa binarke
  • anger1 12.04.05, 22:55
    Za binarkę też się zabierałem, ale 'make' wywala następujący komunikat:

    /usr/local/qt/lib/libqt.so: undefined reference to `XML_SetElementHandler'
    /usr/local/qt/lib/libqt.so: undefined reference to `XML_SetDoctypeDeclHandler'
    /usr/local/qt/lib/libqt.so: undefined reference to `XML_ParserFree'
    /usr/local/qt/lib/libqt.so: undefined reference to `XML_SetCharacterDataHandler'
    /usr/local/qt/lib/libqt.so: undefined reference to `XML_ErrorString'
    /usr/local/qt/lib/libqt.so: undefined reference to `XML_ParseBuffer'
    /usr/local/qt/lib/libqt.so: undefined reference to `XML_ParserCreate'
    /usr/local/qt/lib/libqt.so: undefined reference to `XML_SetUserData'
    /usr/local/qt/lib/libqt.so: undefined reference to `XML_GetErrorCode'
    /usr/local/qt/lib/libqt.so: undefined reference to `XML_GetBuffer'
    /usr/local/qt/lib/libqt.so: undefined reference to `XML_GetCurrentLineNumber'
    collect2: ld returned 1 exit status
    make[4]: *** [../../../bin/uic] Błąd 1
    make[4]: Leaving directory `/usr/local/qt/tools/designer/uic'
    make[3]: *** [sub-uic] Błąd 2
    make[3]: Leaving directory `/usr/local/qt/tools/designer'
    make[2]: *** [sub-designer] Błąd 2
    make[2]: Leaving directory `/usr/local/qt/tools'
    make[1]: *** [sub-tools] Błąd 2
    make[1]: Leaving directory `/usr/local/qt'
    make: *** [init] Błąd 2

    To znaczy, że czego mu brakuje ? :)
  • kell99 13.04.05, 01:10
    pewnie jakiejs libxml, hmm, zabieramy sie od zlej strony do tego. na stronie qt
    z pewnoscia beda wypisane wymagania do kompilacji

Popularne wątki

Nie pamiętasz hasła

lub ?

 

Nie masz jeszcze konta? Zarejestruj się

Nakarm Pajacyka
Agora S.A. - wydawca portalu Gazeta.pl nie ponosi odpowiedzialności za treść wypowiedzi zamieszczanych przez użytkowników Forum. Osoby zamieszczające wypowiedzi naruszające prawo lub prawem chronione dobra osób trzecich mogą ponieść z tego tytułu odpowiedzialność karną lub cywilną. Regulamin.