Dodaj do ulubionych

Tego błędu nikt nie zgłosił?

17.02.20, 01:12
Gdy dodaję zdjęcie poprzez wybranie zdjęcia z dysku, to zdjęcie ląduje pod sygnaturką i mój wpis staje się nieregulaminowy. Przeciągnie zdjęcia też nie działa. Jedynie wklejenie adresu zdjęcia pozawala na poprawne umieszczenie go w oczekiwanym miejscu.

S.
--
Symetryści uważają, że winę za gwałt ponoszą symetrycznie obie strony.
Obserwuj wątek
      • snajper55 Re: Tego błędu nikt nie zgłosił? 18.02.20, 00:25
        marrant napisała:

        > Zdjęcie jest elementem galerii, a nie sygnaturki. To ma tak wyglądać.


        Nie rozumiem.

        Gdy zdjęcie dodaję przez wstawienie adresu zdjęcia, to zdjęcie wstawia się w środek postu, tam gdzie umieściłem kursor i gdzie oczekuję na pojawienie się zdjęcia.

        Tego samego oczekuję gdy wstawiam zdjęcie dwoma pozostałymi sposobami - przez przeciągnięcie lub wybranie z dysku. Niestety, w przypadku tych metod wstawiania zdjęć zdjęcie ląduje poniżej sygnaturki.

        Przecież zdjęcie jest częścią postu, częścią, która ma swoje miejsce wewnątrz treści wpisu a nie obrazkiem nie związanym z wpisem i wiszącym sobie ni przypiął, ni przyłatał za sygnaturką.

        Ten brak konsekwencji jest zamierzony? Kto to wymyślił?

        S.
        --
        Symetryści uważają, że winę za gwałt ponoszą symetrycznie obie strony.
        • marrant Re: Tego błędu nikt nie zgłosił? 19.02.20, 11:39
          Ten brak konsekwencji wynika z tego, że zdjęcia ładowane z dysku lub telefonu są przez nas hostowane.
          W trakcie dodawania zdjęcia jest ono po naszej stronie formatowane i umieszczane jako element dopisany do postu, a jego umieszczenie na serwerze występuje dopiero w momencie wysłania postu. Gdyby było inaczej i zdjęcie umieszczane by było w trakcie pisania postu - w treści, to należałoby "w locie" hostować i usuwać zdjęcie zależnie od tego czy użytkownik wklei czy usunie wygenerowany link. To bardzo komplikowałoby ten mechanizm i powodowałoby gigantyczne lagi przy edycji postu.

          Drugim powodem jest to, że docelowo ten mechanizm zastąpi funkcję fotoforum, w którym to stosowany jest ten typ galerii.

          Decyzja by rozwiązanie tego problemu miało wygląd obecny jest moja. Zapewniam, że ważyłam plusy i minusy każdego z rozwiązań i to jest kompromis UXowo technologiczny.

          • snajper55 Re: Tego błędu nikt nie zgłosił? 20.02.20, 22:58
            marrant napisała:

            > Ten brak konsekwencji wynika z tego, że zdjęcia ładowane z dysku lub telefonu s
            > ą przez nas hostowane.
            > W trakcie dodawania zdjęcia jest ono po naszej stronie formatowane i umieszcza
            > ne jako element dopisany do postu, a jego umieszczenie na serwerze występuje do
            > piero w momencie wysłania postu. Gdyby było inaczej i zdjęcie umieszczane by by
            > ło w trakcie pisania postu - w treści, to należałoby "w locie" hostować i usuwa
            > ć zdjęcie zależnie od tego czy użytkownik wklei czy usunie wygenerowany link. T
            > o bardzo komplikowałoby ten mechanizm i powodowałoby gigantyczne lagi przy edyc
            > ji postu.
            >
            > Drugim powodem jest to, że docelowo ten mechanizm zastąpi funkcję fotoforum, w
            > którym to stosowany jest ten typ galerii.
            >
            > Decyzja by rozwiązanie tego problemu miało wygląd obecny jest moja. Zapewniam,
            > że ważyłam plusy i minusy każdego z rozwiązań i to jest kompromis UXowo technol
            > ogiczny.

            Umieszczanie zdjęcia w treści postu dopiero po wysłaniu nie jest zbyt eleganckie (WYSIWYG), choć rozwiązuje ten problem. Chyba, że z jakiegoś powodu nie można. Za mało wiem.

            Przepraszam za zgryźliwość w pytaniu, ale czasem oceniając jakieś rozwiązanie nie pamięta się o ograniczeniach które wiążą autora rozwiązania.

            S.
            --
            Lichocka u onkologa
            • wariant_b Re: Tego błędu nikt nie zgłosił? 20.02.20, 23:33
              snajper55 napisał:

              > Umieszczanie zdjęcia w treści postu dopiero po wysłaniu nie jest zbyt eleganckie (WYSIWYG),
              > choć rozwiązuje ten problem.

              Ale edytory postów na forum są przecież tekstowe, a nie WYSIWYG.
              Więc dopiero wysłanie postu lub jego podgląd generują konieczność wyświetlenia zdjęcia,
              a w szczególności jego wysłania na serwer, co jest bardziej czasochłonne niż pobieranie
              z uwagi na asymetrię łącz transmisyjnych.

              > Przepraszam za zgryźliwość w pytaniu, ale czasem oceniając jakieś rozwiązanie
              > nie pamięta się o ograniczeniach które wiążą autora rozwiązania.

              Jak mi się wydaje, tutaj "ograniczeniem" było istnienie gotowego kodu dla FotoForum,
              który wystarczyło przystosować, zamiast projektować i kodować od nowa cały mechanizm.

Popularne wątki

Nie pamiętasz hasła

lub ?

 

Nie masz jeszcze konta? Zarejestruj się

Nakarm Pajacyka